Poj 1703(2sat)

Find them, Catch them
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 25758   Accepted: 7780

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source

POJ Monthly--2004.07.18

类似食物链那道题,只不过更简单。首先不能强制给一个人划归到一个组织,另一个到另一个组织,这样做是有后效性的,也就是说你不能确定到底应该是划到哪个组织是正确的。只能确定的条件是如果a是组织1,那么b是组织2,或a是组织2,b是组织1.这不就是2sat吗?只是这里的询问比较简单,可以用并查集来实现。每个人也是拆成两个点,分别代表他在哪个组织中。每来一个条件,就按照2sat的方式加边,只是这里的加边变成了并查集的合并。每个询问的判断,就是根据相应的逻辑判断两点是否在同一集合即可。
#include<cstdio>
#include<algorithm>
#include<vector>
#include<set>
#include<map>
#include<iostream>
#include<string>
#include<cstring>
#include<queue>
using namespace std;
typedef long long LL;
const int maxn = 100000 + 5;
const int INF = 1000000000;

int fa[maxn*2];

int Find(int x){return fa[x]==x?x:fa[x]=Find(fa[x]);}

int main(){
    int n,m;
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        for(int i = 1;i <= 2*n;i++) fa[i] = i;
        for(int i = 0;i < m;i++){
            char s[5];
            int x,y;
            scanf("%s%d%d",s,&x,&y);
            if(s[0] == 'A'){
                int X1 = Find(x);
                int Y1 = Find(y);
                int X2 = Find(x+n);
                int Y2 = Find(y+n);
                if(X1 == Y2 || X2 == Y1){
                    printf("In different gangs.\n");
                }
                else if(X1 == Y1 || X2 == Y2){
                    printf("In the same gang.\n");
                }
                else{
                    printf("Not sure yet.\n");
                }
            }
            else{
                int X1 = Find(x);
                int Y1 = Find(y);
                int X2 = Find(x+n);
                int Y2 = Find(y+n);
                fa[X1] = Y2;
                fa[X2] = Y1;
            }
        }
    }
    return 0;
}


你可能感兴趣的:(Poj 1703(2sat))