Leftmost Digit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12897 Accepted Submission(s): 4934
Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the leftmost digit of N^N.
Sample Input
Sample Output
2
2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
因为N^N = A * 10^X (科学计数法,A即为所求最高位),两边同时取对数得N * log10(N) = log10(A) + X, 得 log10(A) = N * log10(N) - X, 得 A = 10^(N*log10(N) - X), 其中X为N^N结果的位数-1,即[log10(N*N)], 中括号表示取整,所以最终结果为A = 10^(N*log10(N) - [N*log10(N)]).需要注意的是N^N的位数要用__int64类型存储。
#include <stdio.h>
#include <math.h>
int main()
{
int t, n;
double ans;
scanf("%d", &t);
while(t--){
scanf("%d", &n);
ans = n * log10(n);
ans -= (__int64)ans;
ans = pow(10, ans);
printf("%d\n", (int)ans);
}
return 0;
}