poj 3071 Football(概率dp)

题目链接

Football
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3284   Accepted: 1679

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all ij, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins)  = P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
= p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.


题意:2^n支球队打淘汰赛,第1支和第2支打,第2支和第3支打,,,依次类推。已知每支球队战胜另一支球队的概率,问哪支球队夺冠的概率最大?

用p[i][j] 表示i打赢j的概率。

题解:用dp[i][j] 表示第i轮比赛,第j支球队获胜的概率。转移就是:

如果第i轮,第j支球队和第k支球队可能相遇:

dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k]

代码如下:

#include<stdio.h>
#include<iostream>
#include<queue>
#include<algorithm>
#include<string>
#include<string.h>
#include<math.h>
#define nn 1100
using namespace std;
int n;
double dp[10][210];
double p[210][210];
int main()
{
    int i,j,k;
    while(scanf("%d",&n)&&n!=-1)
    {
        for(i=0;i<(1<<n);i++)
        {
            for(j=0;j<(1<<n);j++)
                scanf("%lf",&p[i][j]);
        }
        memset(dp,0,sizeof(dp));
        for(i=0;i<(1<<n);i++)
            dp[0][i]=1.0;
        for(i=1;i<=n;i++)
        {
            for(j=0;j<(1<<n);j++)
            {
                for(k=0;k<(1<<n);k++)
                {
                    if(((j>>(i-1))^1)==(k>>(i-1)))
                        dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k];
                }
            }
        }
        double tem=0;
        int id;
        for(j=0;j<(1<<n);j++)
        {
            if(dp[n][j]>tem)
            {
                tem=dp[n][j];
                id=j;
            }
        }
        printf("%d\n",id+1);
    }
    return 0;
}


你可能感兴趣的:(dp,ACM)