poj2104K-th Number (主席树)

K-th Number
Time Limit: 20000MS   Memory Limit: 65536K
Total Submissions: 46886   Accepted: 15682
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?"
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 10 9 by their absolute values --- the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

Source

Northeastern Europe 2004, Northern Subregion

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page  Go Back  To top


百度搜索可持久化线段树   就出现了这道题  

因为很早就知道了主席树 可惜一直没有看懂文字  无意中在bilibili弹幕网站中看到了讲算法的视频 不可思议 哈哈  

我竟然在B站学算法。。。  视频地址 

http://www.bilibili.com/video/av4619406
这是文字的讲解 
http://seter.is-programmer.com/posts/31907.html

看完视频  按照印象。。。AC了 
慢慢消化   ~
#include <stdio.h>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn=1e5+5;
struct node
{
	int l,r;
	int sum;	
}T[maxn*40];
int root[maxn],a[maxn],cnt,sum;
vector<int>v;
int getid(int x)
{
	return lower_bound(v.begin(),v.end(),x)-v.begin()+1;
}
void update(int l,int r,int &x,int y,int pos)
{
	T[++cnt]=T[y],T[cnt].sum++,x=cnt;
	if(l==r) return ;
	int mid=(l+r)/2;
	if(mid>=pos) update(l,mid,T[x].l,T[y].l,pos);
	else update(mid+1,r,T[x].r,T[y].r,pos);
}
int query(int l,int r,int x,int y,int k)
{
	if(l==r) return l;
	int mid=(l+r)/2;
	int sum=T[T[y].l].sum-T[T[x].l].sum;
	if(sum>=k) return query(l,mid,T[x].l,T[y].l,k);
	else return query(mid+1,r,T[x].r,T[y].r,k-sum);
}
int main()
{
	int n,m;
	scanf("%d %d",&n,&m);
	for(int i=1;i<=n;i++) 
	scanf("%d",&a[i]),v.push_back(a[i]);
	sort(v.begin(),v.end());
	v.erase(unique(v.begin(),v.end()),v.end());
	for(int i=1;i<=n;i++) 
	update(1,n,root[i],root[i-1],getid(a[i]));
	for(int i=0;i<m;i++)
	{
		int a,b,k;
		scanf("%d %d %d",&a,&b,&k);
		printf("%d\n",v[query(1,n,root[a-1],root[b],k)-1]);
	}
	return 0;
}




你可能感兴趣的:(poj,poj2104,主席树,可持久化线段树,2104)