HDOJ 1019 Least Common Multiple

Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output
105
10296

这一题和2028题一样的题,大家可以看看我的2028题

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc=new Scanner(System.in);
        int n=sc.nextInt();
        while(n-->0){
             int m=sc.nextInt();
             int[] a=new int[m];
             int sum=1;
             for(int i=0;i<m;i++){
                 a[i]=sc.nextInt();
                 if(sum<a[i]){
                     sum=a[i];
                 }
             }
             for(int i=0;i<m;i++){
                 sum=Mu(sum,a[i]);
             }
             System.out.println(sum);
        }
    }
    public static int Mu(int x,int y){
        for(int i=1;i<=y;i++){
            if(((x*i)%y)==0){
                x=x*i;
                break;
            }
        }
        return x;
    }
}

你可能感兴趣的:(HDOJ 1019 Least Common Multiple)