hbmy周赛1--A


Age Sort

You are given the ages (in years) of all people of a country with at least 1 year of age. You know thatno individual in that country lives for 100 or more years. Now, you are given a very simple task ofsorting all the ages in ascending order.

Input

There are multiple test cases in the input file. Each case starts with an integer n (0 < n ≤ 2000000), thetotal number of people. In the next line, there are n integers indicating the ages. Input is terminatedwith a case where n = 0. This case should not be processed.

Output

For each case, print a line with n space separated integers. These integers are the ages of that countrysorted in ascending order.Warning: Input Data is pretty big (∼ 25 MB) so use faster IO.

Sample Input

5

3 4 2 1 5

5

2 3 2 3 1

0

Sample Output

1 2 3 4 5

1 2 2 3 3

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;

int compare(int x, int y)
{
	return x < y;
}

int a[2000010];

int main()
{
	int n;
	while (scanf("%d",&n) && n)
	{
		for (int i=0; i<n; i++)
			scanf("%d",&a[i]);
		sort(a,a+n,compare);
		printf("%d",a[0]);
		for (int i=1; i<n; i++)
			printf(" %d",a[i]);
		printf("\n");
	}
	return 0;
	
}


你可能感兴趣的:(周赛)