Oulipo
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7326 Accepted Submission(s): 2939
Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
很基础的kmp。其实题目本身很好做的,就算不理解kmp也能够做的。不过要注意的是,getnext函数求的是next,是str的失败数组。而kmp求的是str与buf的对称性。所以第一个函数的i<len1而第二个i<len2,并且第一次是i=0,j=-1,第二次的时候i=0,j=0。
HDOJ AC代码
#include<stdio.h>
#include<string.h>
#define max 10010
char str[max],buf[max * 100];
int next[max],len1,len2;
void getnext() {
int i = 0,j = -1;
next[i] = j;
while(i < len1){
if(j == -1 || str[i] == str[j]){
++i;++j;
next[i] = j;
}
else j = next[j];
}
}
int kmp() {
int i = 0,j = 0,cnt = 0;
getnext();
while(i < len2){
if(j == -1 || buf[i] == str[j]){
++i;++j;
if(j == len1) cnt++;
}
else j = next[j];
}
return cnt;
}
int main(){
int t;
scanf("%d",&t);
while(t--){
scanf("%s%s",str,buf);
len1 = strlen(str);
len2 = strlen(buf);
printf("%d\n",kmp());
}
return 0;
}
注意,宏定义max的时候不要用10000+10的形式,会RE。
POJ AC代码 (2015 08 10)
#include<stdio.h>
#include<string.h>
#define maxn 10010
char str[maxn],buf[maxn*100];
int next[maxn],len1,len2,cnt;
void getnext(){
int i=0,j=-1;
next[i]=j;
while(i<len1){
if(j==-1||str[i]==str[j]){
++i;++j;
next[i]=j;
}
else j=next[j];
}
}
int kmp(){
int i=0,j=0;
getnext();
while(i<len2){
if(j==-1||buf[i]==str[j]){
++i;++j;
if(j==len1) cnt++;
}
else j=next[j];
}
return cnt;
}
int main(){
int t;
scanf("%d",&t);
while(t--){
scanf("%s%s",str,buf);
cnt=0;
len1=strlen(str);
len2=strlen(buf);
printf("%d\n",kmp());
}
return 0;
}