hznu 1136: Investment(01背包与完全背包的区别)

John never knew he had a grand-uncle, until he received the notary's letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor. John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him.

This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated.

Assume the following bonds are available:

Value Annual interest
4000 400
3000 250

With a capital of 10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000, giving a yearly interest of $1 200.

Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

输入

The first line contains a single positive integer N which is the number of test cases.

The test cases follow.

The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40).

The following line contains a single number: the number d (1 <= d <= 10) of available bonds.

The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.

输出

For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.

样例输入

1
10000 4  //1W块钱存4年
2    //两种选择(1年)
4000 400  //4000块钱获利400
3000 250  //3000块钱获利250

样例输出

14050  //最后的获利

for(v=V; v>w[i]; --v)  //逆序推能够保证 f[v-c[i]] 保存的是状态是 f[i-1][v-c[i]] ,也就是每个物品只被使用了一次;顺序的话 f[v-c[i]] 保存的是 f[i][v-c[i]] ,每个物品有可能被使用多次,也就是完全背包问题的解法。

#include<iostream>
#include<algorithm>
#include<string>
#include<string.h>
#include<vector>
#include<cmath>
#include<map>
#include<stdlib.h>
#include<stdio.h>
#define ll long long
using namespace std;
struct node{
	int a,b;
};
int dp[100001];
int main(){
	int t;
	cin>>t;
	while(t--){
		int n,m;
		cin>>n>>m;
		node x[11];
		int g;
		cin>>g;
		for(int i=0;i<g;++i){
			cin>>x[i].a>>x[i].b;
			x[i].a/=1000;
		}
		while(m--){
			memset(dp,0,sizeof(dp));
			for(int i=0;i<g;++i){
				for(int j=x[i].a;j<=n/1000;j++){
				//for(int j=n/1000;j>=x[i].a;--j){
					dp[j]=max(dp[j],dp[j-x[i].a]+x[i].b);
				}
			}
			n+=dp[n/1000];
		}
		cout<<n<<endl;
	}
	return 0;
}


你可能感兴趣的:(hznu 1136: Investment(01背包与完全背包的区别))