Flying to the Mars
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11043 Accepted Submission(s): 3553
Problem Description
In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example :
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……
After checking up all possible method, we found that 2 is the minimum number of broomsticks needed.
Input
Input file contains multiple test cases.
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
Output
For each case, output the minimum number of broomsticks on a single line.
Sample Input
4 10 20 30 04 5 2 3 4 3 4
Sample Output
题目大意
学飞天扫把,成绩好的可以教成绩差的,一个老师只能有一个学生,同样一个学生也只能有一个老师,一个教学串共用一个扫把,当然也可以一个人没老师没学生自己用一个扫把,求最少扫把数。
错误原因
在数据标记的时候出现了错误,数据的标记值正好也符合循环条件,没有将其排除,造成了不必要的错误。谨记在循环判断的时候讲标记值排除在外。
解题思路
这是一道动态规划与贪心算法相结合的题目,首先将数据做降序排列,然后找递减序列的串数,这个递减序列中的数据可以是在排序之后不挨着,但一定要是值递减。找递减序列的时候,记得每次比较之后,将新的值赋给动态变量,载另其与下一个值作比较
代码
#include<stdio.h>
#include<algorithm>
using namespace std;
int s[3100];
bool cmp(int a,int b)
{
return a>b;
}
int main()
{
int n;
int i,j,sum,nowi;
while(~scanf("%d",&n))
{
for(i=0;i<n;i++)
scanf("%d",&s[i]);
sort(s,s+n,cmp);
sum=0;
for(i=0;i<n;i++)
{
if(s[i]!=-1)
{
nowi=s[i];
s[i]=-1;
sum++;
for(j=i+1;j<n;j++)
{
//if(nowi>s[j])
if(nowi>s[j]&&s[j]!=-1)
//得加上这个一则是节省时间,二则是在比较的时候排除与 -1的比较,避免造成错误
{
nowi=s[j];
s[j]=-1;
}
}
}
}
printf("%d\n",sum);
}
return 0;
}