poj2676--Sudoku(搜索练习5-数独游戏)

Sudoku
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit   Status
Appoint description:   System Crawler  (2013-01-21)

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task.  
poj2676--Sudoku(搜索练习5-数独游戏)_第1张图片

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127

找出每一行,每一列,每一个小方格中可以填的数,进行dfs搜索结果

 

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;
int l[10][10] , r[10][10] , c[10][10] ;
struct node
{
    int x , y ;
} p[100] ;
int num ;
char str[12][12] ;
int dfs(int k)
{
    if( k == num ) return 1 ;
    int x = p[k].x , y = p[k].y ;
    int i ;
    for(i = 1 ; i <= 9 ; i++)
    {
        if( !r[x][i] && !l[y][i] && !c[x/3*3+y/3][i] )
        {
            r[x][i] = l[y][i] = 1 ;
            c[x/3*3+y/3][i] = 1 ;
            str[x][y] = i + '0' ;
            if( dfs(k+1) )
                return 1 ;
            str[x][y] = '0' ;
            r[x][i] = l[y][i] = 0 ;
            c[x/3*3+y/3][i] = 0 ;
        }
    }
    return 0 ;
}
int main()
{
    int t , i , j  ;
    scanf("%d", &t) ;
    while( t-- )
    {
        num = 0 ;
        memset(l,0,sizeof(l)) ;
        memset(r,0,sizeof(r)) ;
        memset(c,0,sizeof(c)) ;
        for(i = 0 ; i < 9 ; i++)
        {
            scanf("%s", str[i]) ;
            for(j = 0 ; j < 9 ; j++)
            {
                if( str[i][j] != '0' )
                {
                    r[i][ str[i][j] - '0' ] = 1 ;
                    l[j][ str[i][j] - '0' ] = 1 ;
                    c[ i/3*3+j/3 ][ str[i][j] - '0' ] = 1 ;
                }
                else
                {
                    p[num].x = i ;
                    p[num++].y = j ;
                }
            }
        }
        dfs(0) ;
        for(i = 0 ; i < 10 ; i++)
            printf("%s\n", str[i]) ;
    }
    return 0;
}


 

你可能感兴趣的:(poj2676--Sudoku(搜索练习5-数独游戏))