zoj 3329 One Person Game(概率(期望)+dp)经典

There is a very simple and interesting one-person game. You have 3 dice, namely Die1Die2 and Die3Die1 has K1 faces.Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1K2K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer 

T (0 < T <= 300) indicating the number of test cases. Then Ttest cases follow. Each test case is a line contains 7 non-negative integers nK1K2K3abc (0 <= n <= 500, 1 < K1K2,K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output

1.142857142857143

1.004651162790698

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3754

大神的解析:http://blog.csdn.net/morgan_xww/article/details/6775853

设 E[i]表示现在分数为i,到结束游戏所要掷骰子的次数的期望值。

#include<iostream>
#include<algorithm>
#include<string>
#include<map>
#include<cmath>
#include<string.h>
#include<stdlib.h>
#include<cstdio>
#define ll long long
using namespace std;
int main(){
	int t;
	cin>>t;
	while(t--){
		double n,k1,k2,k3,d,e,f;
		double p[21]={0};
		cin>>n>>k1>>k2>>k3>>d>>e>>f;
		double p0=1/(k1*k2*k3);
		for(int i=1;i<=k1;++i){
			for(int j=1;j<=k2;++j){
				for(int l=1;l<=k3;++l){
					if(i!=d||j!=e||l!=f)
						p[i+j+l]+=p0;
				}
			}
		}
		double a[521]={0},b[521]={0};
		for(int i=n;i>=0;--i){
			for(int k=3;k<=k1+k2+k3;++k){
				a[i]+=a[i+k]*p[k];
				b[i]+=b[i+k]*p[k];
			}
			a[i]+=p0;b[i]+=1;
		}
		printf("%.15lf\n", b[0]/(1 - a[0]));  
	}
	return 0;
} 


你可能感兴趣的:(zoj 3329 One Person Game(概率(期望)+dp)经典)