Kindergarten Counting Game

Everybody sit down in a circle. Ok. Listen to me carefully.

``Woooooo, you scwewy wabbit!''

Now, could someone tell me how many words I just said?

Input and Output

Input to your program will consist of a series of lines, each line containing multiple words (at least one). A ``word'' is defined as a consecutive sequence of letters (upper and/or lower case).

Your program should output a word count for each line of input. Each word count should be printed on a separate line.

Sample Input

Meep Meep!
I tot I taw a putty tat.
I did! I did! I did taw a putty tat.
Shsssssssssh ... I am hunting wabbits. Heh Heh Heh Heh ...

Sample Output

2
7
10
9
  
  
  
  
#include <stdio.h>
#include <string.h>
int main()
{
    int a, x, i, j, k;
    char s[10000];
    while(gets(s))
    {
        x = 0;
        a = 0;
        k = strlen(s);
        for(i = 0; i <= k - 1; i++)
        {
            if(((s[i] >= 'a' && s[i] <= 'z') || (s[i] >= 'A' && s[i] <= 'Z')) && x == 0)
                {
                    a++;
                    x = 1;
                }
                else if(!((s[i] >= 'a' && s[i] <= 'z') || (s[i] >= 'A' && s[i] <= 'Z')))
                {
                    x = 0;
                }

        }
        printf("%d\n", a);
    }
    return 0;
}


你可能感兴趣的:(编程,C语言)