1411051730-hd-Reverse Number



Reverse Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5222    Accepted Submission(s): 2435


Problem Description
Welcome to 2006'4 computer college programming contest!

Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one... Ha-Ha!

Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.
 

Input
Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow.
 

Output
For each test case, you should output its reverse number, one case per line.
 

Sample Input
   
   
   
   
3 12 -12 1200
 

Sample Output
   
   
   
   
21 -21 2100
 题目大意
        给一个数字按照规则逆序输出。
解题思路
       一开始输入方式是int型的时候超时了,哎,,,,,又没有超过int32位,用得着char字符型吗?纠结,好吧,想要ac不超时输入方式用char型。
代码
#include<stdio.h>
#include<string.h>
char num[110];
int main()
{
	int t;
	int i,j,k,l,len;
	scanf("%d",&t);
	getchar();
	while(t--)
	{
		scanf("%s",num);
		len=strlen(num);
		k=0;
		if(num[0]=='-')
		{
			k=1;//这是第一点要求 
			printf("-");
		}
		j=0;
		for(i=len-1;i>=k;i--)
		{
			if(num[i]=='0')
			    j++;
			else
			    break;
		}//这是第三点要求 
		for(l=i;l>=k;l--)//第二点要求 
		    printf("%c",num[l]);
		for(l=0;l<j;l++)
		    printf("0");
		printf("\n");
	}
	return 0;
}

你可能感兴趣的:(1411051730-hd-Reverse Number)