LightOJ - 1282 Leading and Trailing 对数转换

LightOJ - 1282 Leading and Trailing
一、 题目
Description
You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of n^k.
Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.
Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).
Output
For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that n^k contains at least six digits.
Sample Input
5
123456 1
123456 2
2 31
2 32
29 8751919

Sample Output
Case 1: 123 456
Case 2: 152 936
Case 3: 214 648
Case 4: 429 296
Case 5: 665 669

二、 题目大意
给定n和k,求n^k的前三位和最后三位。

三、 解题思路
后三位可用对1000取模的快速幂解决,前三位可用对数进行转换,log10(n^k)=k*log10(n)。
取log10(n^k)小于3的部分p,pow(10,p)即为答案的前三位, 当n,k较小时,用对数计算的误差可能较大,因此对小数据可用暴力方法直接计算前三位。

四、 代码实现

#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
#include<list>
#include<algorithm>
#include<vector>
#include<cmath>
#include<string>
#include<fstream>
//#pragma comment(linker,"/STACK:1024000000,1024000000")
using namespace std;
const int N=1e6+5;
int n,k;
double eps=1e-5;
long long q_pow(int n,int k)
{
    long long res=1,b=n;
    while(k)
    {
        if(k%2) res*=b;
        res%=1000;
        b*=b;
        b%=1000;

        k/=2;
    }
    return res;
}
int main()
{
    int t,tt=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&k);
        double ans=k*log10(n);
        double p=((int)ans>=2?2:(int)ans)+ans-(int)ans;
        long long res;
        if(n<=10&&k<=20) {
            long long tmp=1;
           for(int i=1;i<=k;i++) tmp*=n;
           while(tmp>=1000) tmp/=10;
           res=tmp;
        }
        else
        res=pow(10,p);
        printf("Case %d: %03lld %03lld\n",++tt,res,q_pow(n,k));
    }
   return 0;
}

你可能感兴趣的:(LightOJ - 1282 Leading and Trailing 对数转换)