HDOJ题目地址:传送门
Elevator
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 62680 Accepted Submission(s): 34449
Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
Output
Print the total time on a single line for each test case.
Sample Input
Sample Output
题意:有一部电梯,从0层开始,在给定的数字列表层数来停留,电梯上一层需要花费6s,下一层需要花费4s,在到达的那层停留5s,最后电梯不需要回到最底层,求最后停留的时间总和
这个题目非常水,一开始还没有看懂题目意思
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<memory.h>
using namespace std;
int main(){
int n;
int result[100];
while(scanf("%d",&n)&&n!=0){
int total=0,start=0;
for(int i=0;i<n;i++){
scanf("%d",&result[i]);
}
for(int i=0;i<n;i++){
//上楼
if(result[i]>start){
total+=(result[i]-start)*6+5;
start=result[i];
}else if(result[i]<start){//下楼
total+=(start-result[i])*4+5;
start=result[i];
}else{//不动
total+=5;
}
}
printf("%d\n",total);
}
}