HDU 2602 最朴实的背包问题


                                 Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19490    Accepted Submission(s): 7720


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
HDU 2602 最朴实的背包问题_第1张图片
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
   
   
   
   
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
   
   
   
   
14 附上代码:
#include <iostream>
#include<stdio.h>
#include<memory.h>
using namespace std;
#define  MAXN 1001
#define  Max(a,b) a>b?a:b
struct Node
{
int volume;
int value;
};
Node node[MAXN];
int main()
{
    int T,n,m,i,j;
    int f[MAXN];
    while(scanf("%d",&T),T)
    {
       scanf("%d%d",&n,&m);
       for(i=1;i<=n;i++)
       scanf("%d",&node[i].value);

       for(i=1;i<=n;i++)
       scanf("%d",&node[i].volume);

       memset(f,0,sizeof(f));

       for(i=1;i<=n;i++)
        for(j=m;j>=node[i].volume;j--)
         {
           f[j]=Max(f[j],f[j-node[i].volume]+node[i].value);
         }
      printf("%d\n",f[m]);
      T--;
    }
   return 0;
}



你可能感兴趣的:(struct,背包问题,算法末班)