HDU 2612 Find a way (BFS+dp)

Find a way

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9689    Accepted Submission(s): 3160

Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input
   
   
   
   
4 4 Y.#@ .... .#.. @..M 4 4 Y.#@ .... .#.. @#.M 5 5 Y..@. .#... .#... @..M. #...#

Sample Output
   
   
   
   
66 88 66

Author
yifenfei

Source
奋斗的年代

Recommend
yifenfei   |   We have carefully selected several similar problems for you:  2717 2579 1195 2605 1429 

题解:给你一个图,图中的标志如题所述,然后求Y 和 M分别到@的最小距离和*11。
         只要分别从两个起始位置分别BFS,然后dp求最小距离和即可。

         注意:起点不能走第二遍了。其他的可以重复走。而且两个人可以当做是不同时间出发的!!!

AC代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
#define INF 0x3f3f3f3f
#define N 210
int n, m;
char map[N][N];
int vis[N][N], dis[N][N][2], flag;
int dir[4][2]={{1,0}, {0,1}, {-1,0}, {0,-1}};
struct node
{
    int x;
	int y;
	int  step;
};

bool check(int next_x,int next_y)
{
	if(next_x>=0&&next_x<n&&next_y>=0&&next_y<m&&!vis[next_x][next_y])
	return true;
	else return false;
}
void bfs(int x, int y)
{
    node head, next;
    head.x=x;
    head.y=y;
    head.step=0;
    vis[x][y]=1;
    queue <node> q;
    q.push(head);

    while(!q.empty())
    {
        head=q.front();
        q.pop();
        for(int i=0; i<4; i++)
        {
            next.x=head.x+dir[i][0];
            next.y=head.y+dir[i][1];
            if(check(next.x,next.y)&&(map[next.x][next.y]=='.'||map[next.x][next.y]=='@'))
            {
                vis[next.x][next.y]=1;
                next.step=head.step+1;
                
                if(map[next.x][next.y]=='@')             
                    dis[next.x][next.y][flag]=min(dis[next.x][next.y][flag], next.step);
                q.push(next);
            }
        }
    }
}

int main()
{
    while(~scanf("%d%d", &n, &m))
    {
        memset(dis, INF, sizeof(dis));
        for(int i=0; i<n; i++)
            scanf("%s", map[i]);

        for(int i=0; i<n; i++)
        for(int j=0; j<m; j++)
        {
            if(map[i][j]=='Y')
            {
                flag=0;
                memset(vis, 0, sizeof(vis));
                bfs(i, j);
            }
            else if(map[i][j]=='M')
            {
                flag=1;
                memset(vis, 0, sizeof(vis));
                bfs(i, j);
            }
        }

        int ans=INF;

        for(int i=0; i<n; i++)
        for(int j=0; j<m; j++)
        {
            if(map[i][j]=='@'&&ans>dis[i][j][0]+dis[i][j][1])
                ans=dis[i][j][0]+dis[i][j][1];
        }
        printf("%d\n", ans*11);
    }
}


你可能感兴趣的:(Way,find,HDU,a,2612,BFS+dp)