POJ 2348/HDU 1525-Euclid's Game辗转相除法(博弈)

Euclid's Game

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8582   Accepted: 3495

Description

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):
         25 7

         11 7

          4 7

          4 3

          1 3

          1 0

an Stan wins.

Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input

34 12
15 24
0 0

Sample Output

Stan wins
Ollie wins

Source

Waterloo local 2002.09.28

题目意思:

给定两个整数a和b。Stan和Ollie轮流从较大的数字中减去较小数字的倍数(正整数倍),并且相减之后结果不能为零。
Stan先手,在自己 的回合中将其中一个数变成0的一方获胜。当双方都采取最优策略时,谁会获胜?

解题思路:

b是a的倍数时是必胜态。
下面分两种情况:①b<2a;②b>2a。
第一种情况无法断定是P/N状态,所以依次减去1倍来判断;
第二种情况是必胜态,说明如下:
设x是使得b-ax<的整数;
假设b-a(x-1)所得为必胜态,该状态的下一状态只能是b-ax。因为假设了b-a(x-1)所得为必胜态,则b-ax只能是必败态(这是正确的)。
即,第二种情况是必胜态得证成立。


#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
int a,b;
void solve()
{
    bool f=true;
    while(1)
    {
        if(a>b) swap(a,b);//使a<b恒成立
        if(b%a==0) break;//必胜态1:b是a的倍数时必胜
        if(b-a>a) break;//必胜态2
        b-=a;//b<2a的情况
        f=!f;//必胜态与必败态轮流出现
    }
    if(f)puts("Stan wins");
    else puts("Ollie wins");
}

int main()
{
    while(cin>>a>>b&&(a||b))
    solve();
    return 0;
}


你可能感兴趣的:(C++,poj,game,HDU,博弈,Euclids,2348,1525)