jobdu 4 excel排序

题目描述:
    Excel可以对一组纪录按任意指定列排序。现请你编写程序实现类似功能。
    对每个测试用例,首先输出1行“Case i:”,其中 i 是测试用例的编号(从1开始)。随后在 N 行中输出按要求排序后的结果,即:当 C=1 时,按学号递增排序;当 C=2时,按姓名的非递减字典序排序;当 C=3  
时,按成绩的非递减排序。当若干学生具有相同姓名或者相同成绩时,则按他们的学号递增排序。
输入:

    测试输入包含若干测试用例。每个测试用例的第1行包含两个整数 N (N<=100000) 和 C,其中 N 是纪录的条数,C 是指定排序的列号。以下有N行,每行包含一条学生纪录。每条学生纪录由学号(6位数字,同组测试中没有重复的学号)、姓名(不超过8位且不包含空格的字符串)、成绩(闭区间[0, 100]内的整数)组成,每个项目间用1个空格隔开。当读到 N=0 时,全部输入结束,相应的结果不要输出。

输出:
    对每个测试用例,首先输出1行“Case i:”,其中 i 是测试用例的编号(从1开始)。随后在 N 行中输出按要求排序后的结果,即:当 C=1 时,按学号递增排序;当 C=2时,按姓名的非递减字典序排序;当 C=3  
时,按成绩的非递减排序。当若干学生具有相同姓名或者相同成绩时,则按他们的学号递增排序。
样例输入:
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
0 0
样例输出:
Case 1:
000001 Zoe 60
000007 James 85
000010 Amy 90
Case 2:
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Case 3:
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct E
{
	char number[10];
	char name[10];
	int score;
}buf[100001];
bool cmp1(E a,E b)
{
	return strcmp(a.number,b.number)<0;
}
bool cmp2(E a,E b)
{
	int temp=strcmp(a.name,b.name);
	if(temp==0)
		return strcmp(a.number,b.number)<0;
	else
		return temp<0;
}
bool cmp3(E a,E b)
{
	if(a.score==b.score)	
		return strcmp(a.number,b.number)<0;
	else
		return a.score<b.score;
}
int main()
{
	int N,i,count=0;
	while(scanf("%d%d",&N,&i)&&(N!=0))
	{
			for(int j=0;j<N;j++)
				scanf("%s%s%d",buf[j].number,buf[j].name,&buf[j].score);
			if(i==1)
				sort(buf,buf+N,cmp1);
			else if(i==2)
				sort(buf,buf+N,cmp2);
			else if(i==3)
				sort(buf,buf+N,cmp3);
			count++;
			printf("Case %d:\n",count);
			for(int k=0;k<N;k++)
			{
				printf("%s %s %d\n",buf[k].number,buf[k].name,buf[k].score);
			}
	}
	return 0;
}

 
  
 
  
 
  
 
  
 
  
 
  
 
  
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int c;
struct Student{
int num;
char name[9];
int score;
bool operator < (const Student &b) const
{
    if(c == 1)
        return num < b.num;
    else if(c == 2)
    {   if(strcmp(name, b.name))
            return strcmp(name, b.name) < 0;
        else
            return num < b.num;
    }
    else if(c == 3)
    {
        if(score != b.score)
            return score < b.score;
        else
            return num < b.num;
    }
}
}buf[100000];
int main()
{
    int n;
    int count = 0;
    while(~scanf("%d%d", &n, &c))
    {
        if(n == 0) break;
        for(int i = 0; i < n; i++)
            scanf("%06d%s%d", &buf[i].num, buf[i].name, &buf[i].score);
        sort(buf, buf+n);
        printf("Case %d:\n", ++count);
        for(int i = 0; i < n; i++)
            printf("%06d %s %d\n", buf[i].num, buf[i].name, buf[i].score);
    }
    return 0;
}


你可能感兴趣的:(jobdu 4 excel排序)