HDU 2044 一只小蜜蜂...

题目:

Description

有一只经过训练的蜜蜂只能爬向右侧相邻的蜂房,不能反向爬行。请编程计算蜜蜂从蜂房a爬到蜂房b的可能路线数。 
其中,蜂房的结构如下所示。 
 

Input

输入数据的第一行是一个整数N,表示测试实例的个数,然后是N 行数据,每行包含两个整数a和b(0<a<b<50)。 

Output

对于每个测试实例,请输出蜜蜂从蜂房a爬到蜂房b的可能路线数,每个实例的输出占一行。 

Sample Input

2
1 2
3 6

Sample Output

1
3

代码:

#include<iostream>
#include<stdio.h>
using namespace std;

long long list[50];

int main()
{
	list[1] = 1;
	list[2] = 2;
	for (int i = 3; i < 50; i++)list[i] = list[i - 1] + list[i - 2];
	int n, a, b;
	cin >> n;
	while (n--)
	{
		cin >> a >> b;
		cout << list[b - a] << endl;
	}
	return 0;
}

你可能感兴趣的:(递归)