Red and Black(BFS)

 

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 21944   Accepted: 11798

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

 

 

      题意:

      给出 n ,m 代表有 n 行 m 列(n,m <= 20),’ . ' 代表红色区域,’ # ‘ 代表黑色区域,’ @ ‘ 代表起点位置,可以往四个方向走,只能走红色不能走黑色,问能走到红色区域的最大可能数是多少。

 

      思路:

      寻找连通块的最大数,BFS,DFS 都可以,简单搜索题。灵活运用 pair 。

 

      AC:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;

typedef pair<int, int> P;

char Map[25][25];
bool vis[25][25];
int n, m, dir[4][2] = {1, 0, 0, 1, -1, 0, 0, -1};

int Search(int x, int y) {
        int sum = 0;

        memset(vis, 0, sizeof(vis));

        queue <P> q;

        vis[x][y] = 1;
        q.push(P(x, y));

        while(!q.empty()) {
                P p = q.front();
                q.pop();
                ++sum;

                for (int i = 0; i < 4; ++i) {
                        P now;
                        now.first = p.first + dir[i][0];
                        now.second = p.second + dir[i][1];

                        if (now.first >= 1 && now.second >= 1 &&
                            now.first <= n && now.second <= m &&
                            !vis[now.first][now.second] && 
                            Map[now.first][now.second] == '.') {
                                    vis[now.first][now.second] = 1;
                                    q.push(now);
                            }
                }

        }

        return sum;
}

int main () {
       // freopen("test.in", "r", stdin);

        while (~scanf("%d%d", &m, &n) && (n + m)) {

                int sx, sy;

                for (int i = 1; i <= n; ++i) {
                        for (int j = 1; j <= m; ++j) {
                                scanf(" %c", &Map[i][j]);
                                if (Map[i][j] == '@') {
                                        sx = i;
                                        sy = j;
                                }
                        }
                }

                Map[sx][sy] = '.';

                printf("%d\n", Search(sx, sy));
        }

        return 0;
}

 

 

 

你可能感兴趣的:(bfs)