Charm Bracelet(01背包)

Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 18028   Accepted: 8237

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

 

    题意:

    给出N(1到3402)颗钻石,M(1到12880)总容量。再给出N颗每颗钻石的w(1到12880)容量和v价值。求在不超过总容量M的情况下往包放钻石的最大价值。

   

    思路:

    01背包问题。没有特殊条件(恰好装满),只要求求最大值故初始化为0。

 

    AC:

#include<stdio.h>
#include<string.h>
int w[4000],d[4000];
int dp[15000];

int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
	memset(dp,0,sizeof(dp));
	for(int i=1;i<=n;i++)
		scanf("%d%d",&w[i],&d[i]);
	for(int i=1;i<=n;i++)
		for(int j=m;j>=w[i];j--)
			dp[j]=(dp[j]>dp[j-w[i]]+d[i]?dp[j]:dp[j-w[i]]+d[i]);
	printf("%d\n",dp[m]);
	}
	return 0;
}

 

 

 

你可能感兴趣的:(char)