关于在计算中乘法溢出Calculate S(n) 2015-02-02 13:10 36人阅读 评论(0) 收藏


A - Calculate S(n)
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

Calculate S(n).

S(n)=1 3+2 3 +3 3 +......+n 3 .
 

Input

Each line will contain one integer N(1 < n < 1000000000). Process to end of file.
 

Output

For each case, output the last four dights of S(N) in one line.
 

Sample Input

       
1 2
 

Sample Output

       
0001 0009
 
AC代码
#include <stdio.h>

int main()
{
    __int64 n,sum;
    while (scanf("%I64d",&n)!=EOF)
    {
        sum=0;
        n=n%10000;
        sum=(n*(n+1)/2)*(n*(n+1)/2)%10000;//  为了防止计算sum中乘法溢出将n=n%10000;因为要求得后4位数。
        printf("%04I64d\n",sum);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

你可能感兴趣的:(计算)