模拟 --- 字符串统计

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 69434    Accepted Submission(s): 25788


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

 

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
 
 
Sample Output
red
pink

 闲来无聊,水一题。

【题目来源】

http://acm.hdu.edu.cn/showproblem.php?pid=1004

【题目大意】

首先输入一个数n,表示输入的气球个数,然后输入n行字符串,表示气球的颜色,任务就是统计出现的气球,输出个数多的气球颜色。

【题目分析】

不是很难,水题一道。

【AC代码】

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<cstdlib>
#include<algorithm>
using namespace std;
struct Node
{
    char color[25];
    int cnt;
};
Node a[1010];
bool cmp(Node x,Node y)
{
    return x.cnt>y.cnt;
}
int main()
{
    int n;
    while(scanf("%d",&n),n)
    {
        int i,j;
        for(i=0;i<1010;i++)
           a[i].cnt=0;
        for(i=0;i<n;i++)
        {
            scanf("%s",a[i].color);
        }
        for(i=0;i<n;i++)
        {
            for(j=i+1;j<n;j++)
            {
                 if(!strcmp(a[i].color,a[j].color))
                    a[i].cnt++;
            }
        }
        sort(a,a+n,cmp);
        printf("%s\n",a[0].color);
    }
    return 0;
}

 

你可能感兴趣的:(字符串)