1、实验拓扑

华为vrrp rstp 链路聚合 端口组_第1张图片

2、复习之间配置过的rstp和lacp链路聚合
LSW1
#
vlan batch 10 20 30配置vlan
stp enable 开启生成树协议
stp mode rstp 选择生成树协议模式为rstp
stp instance 0 root primary 配置交换机为生成树的主根
#
interface Eth-Trunk1 配置链路聚合模式为lacp
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 10 20 30
mode lacp-static 选择模式为LACP
max active-linknumber 1 配置活动链路为1条,备份一条。根据实际情况配置
#
interface GigabitEthernet0/0/1
eth-trunk 1
interface GigabitEthernet0/0/2
eth-trunk 1
#
interface GigabitEthernet0/0/3
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 2 to 4094
#
LSW2
vlan batch 10 20 30配置vlan
stp enable 开启生成树协议
stp mode rstp 选择生成树协议模式为rstp
stp instance 0 root secondary 配置交换机为生成树的次根
#
interface Eth-Trunk1 配置链路聚合模式为lacp
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 10 20 30
mode lacp-static 选择模式为LACP
max active-linknumber 1 配置活动链路为1条,备份一条。根据实际情况配置
#
interface GigabitEthernet0/0/1
eth-trunk 1
interface GigabitEthernet0/0/2
eth-trunk 1
#
interface GigabitEthernet0/0/3
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 2 to 4094
#
LSW3
vlan batch 10 20 30 创建vlan
stp enable 开启生成树
stp mode rstp 配置生成树模式为rstp
#
interface GigabitEthernet0/0/1 上联口配置
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/2 上联口配置
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 2 to 4094
#
port-group 1 配置端口组,组中添加成员,相同配置输入一次命令就可以
group-member GigabitEthernet0/0/1
group-member GigabitEthernet0/0/2
3、vrrp概念
在VRRP协议中,有两组重要的概念:VRRP路由器和虚拟路由器,主控路由器和备份路由器。VRRP路由器是指运行VRRP的路由器,是物理实体;虚拟路由器是指VRRP协议创建的,是逻辑概念。一组VRRP路由器协同工作,共同构成一台虚拟路由器。该虚拟路由器对外表现为一个具有唯一固定的IP地址和MAC地址的逻辑路由器。处于同一个VRRP组中的路由器具有两种互斥的角色:主控路由器和备份路由器,一个VRRP组中有且只有一台处于主控角色的路由器,可以有一个或者多个处于备份角色的路由器VRRP协议从路由器组中选出一台作为主控路由器,负责ARP解析和转发IP数据包,组中的其他路由器作为备份的角色并处于待命状态,当由于某种原因主控路由器发生故障时,其中的一台备份路由器能在瞬间的时延后升级为主控路由器,由于此切换非常迅速而且不用改变IP地址和MAC地址,故对终端使用者系统是透明的。
4、vrrp配置
LSW1
#
interface Vlanif10 配置vlan10中sw1为主
ip address 192.168.1.253 255.255.255.0
vrrp vrid 1 virtual-ip 192.168.1.254
vrrp vrid 1 priority 120
#
interface Vlanif20 配置vlan20中sw1为主
ip address 192.168.2.253 255.255.255.0
vrrp vrid 2 virtual-ip 192.168.2.254
vrrp vrid 2 priority 120
#
interface Vlanif30配置vlan30中sw1为备
ip address 192.168.3.253 255.255.255.0
vrrp vrid 3 virtual-ip 192.168.3.254
#

  • LSW2
    #
    interface Vlanif10
    配置vlan10中sw2为备
    ip address 192.168.1.253 255.255.255.0
    vrrp vrid 1 virtual-ip 192.168.1.254
    #
    interface Vlanif20配置vlan20中sw2为备
    ip address 192.168.2.253 255.255.255.0
    vrrp vrid 2 virtual-ip 192.168.2.254

#
interface Vlanif30配置vlan30中sw2为主
ip address 192.168.3.253 255.255.255.0
vrrp vrid 3 virtual-ip 192.168.3.254
vrrp vrid 2 priority 120