ipv6 隧道:
(1)6to4隧道:(用于两台交换或路由之间跨不支持ipv6的结构)
37A#sh run
System software version : RGNOS V4.11(2) Build Jul 15 2006 Release
Building configuration...
Current configuration : 391 bytes
Current configuration : 391 bytes
!
version 1.0
!
hostname 37A
vlan 1
!
interface GigabitEthernet 0/12
no switchport
ip address 192.168.0.1 255.255.255.0
version 1.0
!
hostname 37A
vlan 1
!
interface GigabitEthernet 0/12
no switchport
ip address 192.168.0.1 255.255.255.0
!
interface Vlan 1
ipv6 address 2001::1/64
ipv6 enable
no ipv6 nd suppress-ra
interface Vlan 1
ipv6 address 2001::1/64
ipv6 enable
no ipv6 nd suppress-ra
!
!
interface Tunnel 0
tunnel source 192.168.0.1
tunnel destination 192.168.1.2
ipv6 address 3fff::1/64
ipv6 enable
!
interface Tunnel 0
tunnel source 192.168.0.1
tunnel destination 192.168.1.2
ipv6 address 3fff::1/64
ipv6 enable
!
!
ipv6 route ::/0 3fff::2
!
ipv6 route ::/0 3fff::2
end
37A# ping 2002::1
% Unrecognized host or address.
% Unrecognized host or address.
37A# ping ipv 2002::1
!!!!!
Ping statistics for 2002::1:
Packets: Send=5, Receive=5, RcvBad=0, Lost=0,<0% loss>
*****************************************************************
37B#
37B#sh run
!!!!!
Ping statistics for 2002::1:
Packets: Send=5, Receive=5, RcvBad=0, Lost=0,<0% loss>
*****************************************************************
37B#
37B#sh run
System software version : RGNOS V4.11(2) Build Jul 15 2006 Release
Building configuration...
Current configuration : 391 bytes
Current configuration : 391 bytes
!
version 1.0
!
hostname 37B
vlan 1
!
interface GigabitEthernet 0/12
no switchport
ip address 192.168.1.2 255.255.255.0
version 1.0
!
hostname 37B
vlan 1
!
interface GigabitEthernet 0/12
no switchport
ip address 192.168.1.2 255.255.255.0
!
interface Vlan 1
ipv6 address 2002::1/64
ipv6 enable
no ipv6 nd suppress-ra
interface Vlan 1
ipv6 address 2002::1/64
ipv6 enable
no ipv6 nd suppress-ra
!
!
interface Tunnel 0
tunnel source 192.168.1.2
tunnel destination 192.168.0.1
ipv6 address 3fff::2/64
ipv6 enable
!
interface Tunnel 0
tunnel source 192.168.1.2
tunnel destination 192.168.0.1
ipv6 address 3fff::2/64
ipv6 enable
!
!
ipv6 route ::/0 3fff::1
!
ipv6 route ::/0 3fff::1
end
37B# ping ipv 3fff::1
!!!!!
Ping statistics for 3fff::1:
Packets: Send=5, Receive=5, RcvBad=0, Lost=0,<0% loss>
!!!!!
Ping statistics for 3fff::1:
Packets: Send=5, Receive=5, RcvBad=0, Lost=0,<0% loss>
37B#ping ipv 2001::1
!!!!!
Ping statistics for 2001::1:
Packets: Send=5, Receive=5, RcvBad=0, Lost=0,<0% loss>
!!!!!
Ping statistics for 2001::1:
Packets: Send=5, Receive=5, RcvBad=0, Lost=0,<0% loss>
&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
(2) ISATAP隧道(用于支持ipv6的设备与pc机的结构)
37A#sh run
System software version : RGNOS V4.11(2) Build Jul 15 2006 Release
Building configuration...
Current configuration : 211 bytes
Current configuration : 211 bytes
!
version 1.0
!
hostname 37A
vlan 1
!
interface GigabitEthernet 0/12
no switchport
ip address 1.1.1.1 255.255.255.0
version 1.0
!
hostname 37A
vlan 1
!
interface GigabitEthernet 0/12
no switchport
ip address 1.1.1.1 255.255.255.0
!
interface Vlan 1
ip address 192.168.0.1 255.255.255.0
interface Vlan 1
ip address 192.168.0.1 255.255.255.0
!
!
!
!
!
end
******************************************************
37B#sh run
System software version : RGNOS V4.11(2) Build Jul 15 2006 Release
Building configuration...
Current configuration : 529 bytes
Current configuration : 529 bytes
!
version 1.0
!
hostname 37B
vlan 1
!
interface GigabitEthernet 0/12
no switchport
ip address 1.1.1.2 255.255.255.0
version 1.0
!
hostname 37B
vlan 1
!
interface GigabitEthernet 0/12
no switchport
ip address 1.1.1.2 255.255.255.0
!
interface Vlan 1
ipv6 address 2005::1/64
ipv6 enable
no ipv6 nd suppress-ra
interface Vlan 1
ipv6 address 2005::1/64
ipv6 enable
no ipv6 nd suppress-ra
!
interface Loopback 0
ipv6 address 2002::1/64
ipv6 enable
!
!
interface Tunnel 0
tunnel mode ipv6ip isatap
tunnel source GigabitEthernet 0/12
ipv6 address 2001::/64 eui-64
ipv6 enable
no ipv6 nd suppress-ra
interface Loopback 0
ipv6 address 2002::1/64
ipv6 enable
!
!
interface Tunnel 0
tunnel mode ipv6ip isatap
tunnel source GigabitEthernet 0/12
ipv6 address 2001::/64 eui-64
ipv6 enable
no ipv6 nd suppress-ra
!
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet 0/12 1.1.1.1 1 enabled
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet 0/12 1.1.1.1 1 enabled
end
*******************************************************
pc机端配置:
netsh interface ipv6 isatap set router name=1.1.1.2 ,该命令可以使主机将路由器请求报文封状在IPv4中发给ISATAP隧道以获得IPv6相关参数。