IPv6 Provider Edge_第1张图片

CE客户为IPv6路由,ISP内部使用IPv4地址,通过MP-BGP跨越骨干网穿越IPv6前缀.

 

CE1:

interface FastEthernet1/0
no ip address
duplex auto
speed auto
ipv6 address 12::1/64
ipv6 rip cisco enable
!
ipv6 router rip cisco

 

CE2:

interface FastEthernet1/0
no ip address
duplex auto
speed auto
ipv6 address 45::5/64
ipv6 rip cisco enable
!
ipv6 router rip cisco

 

PE1:

interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip router isis
ipv6 address 2::2/128
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
ipv6 address 12::2/64
ipv6 rip cisco enable
ipv6 rip cisco default-information originate //下放一条默认路由给CE
!
interface FastEthernet1/1
ip address 23.23.23.2 255.255.255.0
ip router isis
duplex auto
speed auto
mpls ip
!
router isis
net 49.0001.2222.2222.2222.00
!
router bgp 1
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 1
neighbor 4.4.4.4 update-source Loopback0
!
address-family ipv4
  neighbor 4.4.4.4 activate
exit-address-family
!
address-family ipv6
  redistribute rip cisco include-connected
  neighbor 4.4.4.4 activate //激活IPv6对等体
  neighbor 4.4.4.4 send-label //让MPLS能够为IPv6前缀分发标签
exit-address-family
!   

 

P:

interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip router isis
!
interface FastEthernet1/0
ip address 23.23.23.3 255.255.255.0
ip router isis
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/1
ip address 34.34.34.3 255.255.255.0
ip router isis
duplex auto
speed auto
mpls ip
!
router isis
net 49.0001.3333.3333.3333.00

 

PE2:

interface Loopback0
ip address 4.4.4.4 255.255.255.255
ip router isis
ipv6 address 4::4/128
!
interface FastEthernet1/0
ip address 34.34.34.4 255.255.255.0
ip router isis
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
ipv6 address 45::4/64
ipv6 rip cisco enable
ipv6 rip cisco default-information originate //下放一条默认路由给CE
!
router isis
net 49.0001.4444.4444.4444.00
!
router bgp 1
bgp router-id 4.4.4.4
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 1
neighbor 2.2.2.2 update-source Loopback0
!
address-family ipv4
  neighbor 2.2.2.2 activate
exit-address-family
!
address-family ipv6
  redistribute rip cisco include-connected
  neighbor 2.2.2.2 activate //激活IPv6对等体
  neighbor 2.2.2.2 send-label //让MPLS能够为IPv6前缀分发标签
exit-address-family
!

 

能够收到PE2发过来的前缀45::/64

IPv6 Provider Edge_第2张图片

MPLS为IPv6前缀分发标签,使用::FFFF+32位IPv4地址填充下一跳

IPv6 Provider Edge_第3张图片

 

IPv6 Provider Edge_第4张图片

IPv6 Provider Edge_第5张图片