基础练习 杨辉三角形

问题描述
杨辉三角形又称Pascal三角形,它的第i+1行是(a+b)i的展开式的系数。
它的一个重要性质是:三角形中的每个数字等于它两肩上的数字相加。
下面给出了杨辉三角形的前4行:
1
1 1
1 2 1
1 3 3 1
给出n,输出它的前n行。
输入格式
输入包含一个数n。
输出格式
输出杨辉三角形的前n行。每一行从这一行的第一个数开始依次输出,中间使用一个空格分隔。请不要在前面输出多余的空格。
样例输入
4
样例输出
1
1 1
1 2 1
1 3 3 1
数据规模与约定
1 <= n <= 34。

import java.io.BufferedReader;
import java.io.InputStreamReader;

public class Main {
    private static int[][] YangHui(int n){
        int [][] a = new int[n][];
        for(int i = 1; i < n+1; i++){
            a[i-1] = new int[i];
            a[i-1][0]=1;
            for(int j = 2; j < i; j++){
                a[i-1][j-1]=a[i-2][j-2]+a[i-2][j-1];
            }
            a[i-1][i-1] = 1;
        }
        return a;
    }

    private static void YangHui_show(int[][] a){
        for (int [] e:a
             ) {
            for (int r:e
                 ) {
                System.out.print(r+" ");
            }
            System.out.println();
        }
    }
    public static void main(String[] args){
        int n;
        BufferedReader bufferedReader = new BufferedReader(new InputStreamReader(System.in));
        String s = null;
        try{
            s = bufferedReader.readLine();
            n = Integer.parseInt(s);
            //System.out.println(n);
            int a[][] = YangHui(n);
            YangHui_show(a);
        }catch (Exception e){
            System.out.println(e);
        }
    }
}

你可能感兴趣的:(基础练习 杨辉三角形)