A - Period UVA - 1328---KMP最小循环节

第二天叫醒我的不是闹钟,是梦想!

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and
126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 ≤ i ≤ N)
we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be
written as AK, that is A concatenated K times, for some string A. Of course, we also want to know
the period K.
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains
N (2 ≤ N ≤ 1000000) the size of the string S. The second line contains the string S. The input file
ends with a line, having the number zero on it.
Output
For each test case, output ‘Test case #’ and the consecutive test case number on a single line; then, for
each prefix with length i that has a period K > 1, output the prefix size i and the period K separated
by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4
题意:对于串的每一个前缀是否具有循环节。输出循环节的前缀长度和k,k就是这个循环节循环了几次构成这个前缀。
最小循环节怎么求呢?
对于一个长度为n的字符串的,它的最小循环节为n-next[n].循环的次数就是n/(n-next[n]),这个倍数一定要大于1。如果是完美的循环节的话,那就是n%(n-next[n])==0;
这道题先求出next[i]数组,然后根据前缀遍历一遍,判断哪些前缀具有循环节。
//求最小循环节

#include<bits/stdc++.h>
using namespace std;
const int N=1e6+10;
int f[N];
int n;
char s[N];
void init()
{
  for(int i=2,j=0;i<=n;i++)
  {
    while(j&&s[i]!=s[j+1]) j=f[j];
    if(s[i]==s[j+1]) j++;
    f[i]=j;
  }
}
int main()
{
  int k=0;
  while(~scanf("%d",&n)&&n)
  {
    memset(f,0,sizeof f);
    cin>>(s+1);
    printf("Test case #%d\n",++k);
    init();
    for(int i=2;i<=n;i++)
    {
      int x=i-f[i];
      if(i%x==0&&i!=x)//为什么i!=x,因为循环的次数一定要大于1
      {
        printf("%d %d\n",i,i/x);
      }
    }
    printf("\n");
  }
}

你可能感兴趣的:(KMP)