PAT甲级练习1011. World Cup Betting (20)

1011. World Cup Betting (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.0  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
Sample Output
T T W 37.98
简单的题,结果还是卡了一会。

直接用三个数组存好了,结果用了ArrayList好像有点多此一举了。。

需要注意的点:

1. java中double运算不精确!!!应该用BigDecimal来进行运算

2. 存到ArrayList中的数组应该是个引用!!!应该每次新建一个存入


import java.math.BigDecimal;
import java.util.ArrayList;
import java.util.Scanner;

public class Main {
	
	public static void main(String[] args) {		
		
		String[] result = {"W", "T", "L"};
		ArrayList betInfos = new ArrayList();
		//double[] betInfo = new double[3];//放入ArrayList的是引用值,此处应该是在下面新建
		int[] maxNum = new int[3];
		
		Scanner s = new Scanner(System.in);
		
		for(int i=0; i<3; i++){
			BigDecimal[] betInfo = new BigDecimal[3];
			BigDecimal max = BigDecimal.ZERO;
			for(int j=0; j<3; j++){
				betInfo[j] = new BigDecimal(s.next());
				if(betInfo[j].compareTo(max) == 1){
					max = betInfo[j];
					maxNum[i] = j;
				}
			}
			betInfos.add(betInfo);
		}

		BigDecimal maxProfit = betInfos.get(0)[maxNum[0]].multiply(betInfos.get(1)[maxNum[1]]).multiply(betInfos.get(2)[maxNum[2]]).multiply(BigDecimal.valueOf(0.65)).subtract(BigDecimal.ONE).multiply(BigDecimal.valueOf(2));
		
		System.out.printf("%s %s %s %.2f", result[maxNum[0]], result[maxNum[1]], result[maxNum[2]], maxProfit.doubleValue());
		
	}
}

你可能感兴趣的:(PAT甲级练习)