hdu 1028

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27981    Accepted Submission(s): 19219


 

Problem Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

 

 

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

 

 

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

 

 

Sample Input

 

4 10 20

 

 

Sample Output

 

5 42 627

求一个数的组合方式,这是经典的母函数求解的问题。

原问题可以转换为求多项式乘积(1+x+x^2+...+x^n)*(1+x^2+x^4+...+x^2n)*...(1+x^n+....)中x^n的系数

话不多说,我们先上代码。

import java.util.Scanner;

public class Main {
    public static void main(String[] args){
        Scanner in=new Scanner(System.in);
        while(in.hasNext()){
            int target=in.nextInt();
            System.out.println(getResult(target));
        }
    }
    public static int getResult(int n){
        int[] c1=new int[n+1];
        int[] c2=new int[n+1];
        for(int i=0;i<=n;i++){
            c1[i]=1;
            c2[i]=0;
        }
        //由于从第一项乘到最后一项需要乘n-1次
        for(int i=2;i<=n;i++){
            //由于要算出x^n的系数,所以要遍历乘积中小于等于n的项与右边的表达式相乘
            for(int j=0;j<=n;j++){
                //每次乘积的右边项都是以i递增的
                for(int k=0;j+k<=n;k+=i){
                    c2[j+k]+=c1[j];
                }
            }
            for(int j=0;j<=n;j++){
                //每做完一次乘法,要交换依次c1,c2的位置,以便做下面的乘法
                c1[j]=c2[j];
                c2[j]=0;
            }
        }
        return c1[n];
    }
}

 

你可能感兴趣的:(算法)