杭电ACM题1004

杭电题1004

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input

5 green red blue red red 3 pink orange pink 0
Sample Output

red pink


#include "iostream"
using namespace std ;

int main(){  
	int n;
	char a[1000][15];
	while(cin>>n){ 
		if(n==0)break;
		int b[100];
		for (int i = 1; i <= n; i++)
			b[i]=0;

		for (int i = 1;i<= n; i++)
			cin>>a[i];

		//出现频率的记录
		for (int i = 1; i <=n; i++)
			for (int j = i+1; j <= n; j++)
				if (strcmp(a[i],a[j])==0)
					b[i]++;
		//找到频率高的
		int max=b[1];
		int k=1;
		for (int i = 1; i <=n; i++)
			if (b[i]>max){
				max=b[i];
				k=i;
			}
			cout<

我现在还没有想明白,为何不能通过杭电的ACM编辑器,目前就这样吧,我还有其他事要忙,改天再修改与更进!

杭电ACM题1004_第1张图片

上面的代码,小编做了小小的修改,现在可以通过杭电的编辑器了。

#include "iostream"
using namespace std ;

int main(){  
	int n;
	char a[1000][15];
	int b[1000];
	while(cin>>n){ 
		if(n==0)break;

		for (int i = 1;i<= n; i++)
			cin>>a[i];

		//出现频率的记录
		for (int i = 1; i <=n; i++){
			b[i]=0;
			for (int j = i+1; j <= n; j++)
				if (strcmp(a[i],a[j])==0)
					b[i]++;
		}
		//找到频率高的
		int max=b[1];
		int k=1;
		for (int i = 1; i <=n; i++)
			if (b[i]>max){
				max=b[i];
				k=i;
			}
			cout<

你可能感兴趣的:(ACM)