hdu1005



Number Sequence Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 106724    Accepted Submission(s): 25943


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.

Sample Input
 
   
1 1 3 1 2 10 0 0 0
 

Sample Output
 
   
2 5

原来认为这道题用递归算法但是oj上表示堆栈超出后来用数组做
# include 
int f(int a,int b,int n)
{
	if(n==1)
	return 1;
	else if(n==2)
	return 1;
	else
	return (((a*f(a,b,n-1))+(b*f(a,b,n-2)))%7);
}
int main()
{
int x,y,z;
int t;
scanf("%d%d%d",&x,&y,&z);
while(x!=0&&y!=0&&z!=0)
{
	t=f(x,y,z);
	printf("%d\n",t);
scanf("%d%d%d",&x,&y,&z);
}
return 0;
}

下面用数组写的

# include 
int main()
{
int f[200];
int a,b,n,i;
while(scanf("%d%d%d",&a,&b,&n)&&a&&b&&n)
{
if(n>=3)
{
f[1]=1;f[2]=1;
for(i=3;i<200;i++)
{
f[i]=(a*f[i-1]+b*f[i-2])%7;
}
if(n==0)
printf("%d\n",f[i]);
else 
printf("%d\n",f[n]);
}
else 
printf("1\n");
}
return 0;
}


你可能感兴趣的:(acm)