Java - 杭电1003 Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 210235    Accepted Submission(s): 49331


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
 
   
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
 
   
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L
 

最容易想到的就是枚举,但是很可能会超时

import java.util.Scanner;
public class Main {
    public static void main(String[] args){
        Scanner sc=new Scanner(System.in);
        int t = sc.nextInt();
        for(int i=0 ;imax){
    				start = i+1;
    				end = j+1;
    				max = sum;
    			}
    		}
    	}
    	System.out.println(max+" "+start+" "+end);
    }
}

果然超时。。。。


import java.util.Scanner;
public class Main {
    public static void main(String[] args){
        Scanner sc=new Scanner(System.in);
        int t = sc.nextInt();
        for(int i=1 ;i<=t ;i++){
        	int n = sc.nextInt();
        	int maxsum = sc.nextInt();
        	
        	int maxleft = 0;
        	int maxright = 0 ;
        	int thisleft = 0;
        	int thissum = maxsum;
        	
        	if(thissum<0){
        		thissum = 0;
        		thisleft = 1;
        	}
        	for(int j=1 ;jmaxsum){
        			maxsum = thissum;
        			maxleft = thisleft;
        			maxright = j;
        		}
        		if(thissum<0){
        			thisleft = j+1;
        			thissum = 0;
        		}
        	}
//        	System.out.printf("Case %d:\n%d %d %d\n", i,maxsum,maxleft+1,maxright+1);
//        	if(i!=t){
//        		System.out.println();
//        	}
        	
        	System.out.println("Case "+i+":");  
        	System.out.println(maxsum+" "+(maxleft+1)+" "+(maxright+1));  
        	if(i!=t){  
        		System.out.println();  
        	}
        	
        }
    }
}


ac。。。。


你可能感兴趣的:(HDU)