蓝桥杯:数组输出

题目描述

输入一个3行4列的数组,找出该数组中绝对值最大的元素、输出该元素及其两个下标值。如有多个输出行号最小的,还有多个的话输出列号最小的。 

输入

输出

样例输入

1  2  3  5 
-2  5  8  9 
6  -7  5  3 

样例输出

9 2 4

编程代码如下:

public static void main(String[] args) {

Scanner sc = new Scanner(System.in);

int[][] arr = new int[3][4];

for(int i=0;i<3;i++){

for(int j=0;j<4;j++){

arr[i][j] = sc.nextInt();

}

}

int max = arr[0][0];

int abs = 0;

int a=0,b=0;

for(int i=0;i<3;i++){

for(int j=0;j<4;j++){

abs = Math.abs(arr[i][j]);

max = Math.abs(max);

if(abs>max){

max = arr[i][j];

a = i;

b = j;

}

}

}

System.out.println(max+" "+(a+1)+" "+(b+1));

 

}

你可能感兴趣的:(算法编程,编程算法)