2016大连现场赛C题 威佐夫博弈

Problem Description
Two people face two piles of stones and make a game. They take turns to take stones. As game rules, there are two different methods of taking stones: One scheme is that you can take any number of stones in any one pile while the alternative is to take the same amount of stones at the same time in two piles. In the end, the first person taking all the stones is winner.Now,giving the initial number of two stones, can you win this game if you are the first to take stones and both sides have taken the best strategy?

Input
Input contains multiple sets of test data.Each test data occupies one line,containing two non-negative integers a andb,representing the number of two stones.a and b are not more than 10^100.

Output
For each test data,output answer on one line.1 means you are the winner,otherwise output 0.

Sample Input
2 1 8 4 4 7

Sample Output
0 1 0

Source
2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)

题意:全裸的威佐夫博弈if(a-b)*(sqrt(5)-1)=a则后手赢,但是输入的两个数长度长达100位

思路:

威佐夫博弈:a为a、b中较小的数,先手是否会赢 -----> (sqrt(5)+1)/2*(b-a)==a? lose:win

而对于该题,数据范围是10的100次方,还有小数乘法 ----> 黄金分割率需要精确到小数点后100位 ----> 通过二分求解。

import java.math.BigDecimal;
import java.math.BigInteger;
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {

        BigDecimal sqrt5 = sqrt(new BigDecimal("5"), 120);
        BigDecimal _2 = new BigDecimal("2");
        Scanner in = new Scanner(System.in);
        BigDecimal n, m;
        while (in.hasNextBigDecimal()) {
            n = in.nextBigDecimal();
            m = in.nextBigDecimal();
            if (n.compareTo(m) < 0) {
                BigDecimal t = n;
                n = m;
                m = t;
            }
            BigDecimal k = n.subtract(m);

            n = k.multiply(BigDecimal.ONE.add(sqrt5)).divide(_2);
            BigInteger n2 = n.toBigInteger();
            BigInteger m2 = m.toBigInteger();
            System.out.println(n2.compareTo(m2) == 0 ? "0" : "1");

        }
    }
    private static BigDecimal sqrt(BigDecimal x, int n) {
        BigDecimal ans = BigDecimal.ZERO;
        BigDecimal eps = BigDecimal.ONE;
        for (int i = 0; i < n; ++i) {
            while (ans.pow(2).compareTo(x) < 0) {
                ans = ans.add(eps);
            }
            ans = ans.subtract(eps);
            eps = eps.divide(BigDecimal.TEN);
        }
        return ans;
    }
}

你可能感兴趣的:(2016大连现场赛C题 威佐夫博弈)