IPv6 EIGRP

1.实验目的

通过本实验可以掌握

1)启用IPv6流量转发

2IPv6 EIGRP 配置和调试

2.拓扑结构

实验拓扑如图21-4所示。

                                      21-4 IPv6 EIGRP

3.实验步骤

步骤1:配置路由器R1

R1(config)#ipv6 unicast-routing

R1(config)#ipv6 router eigrp 1    //配置IPv6 EIGRP

R1(config-rtr)#router-id 1.1.1.1  //配置路由器ID

R1(config-rtr)#no shutdown     // 启动IPv6 EIGRP 进程

R1(config-rtr)#redistribute connected metric 10000 100 255 1 1500 //将直连重分布到IPv6 EIGRP

 

R1(config)#interface Loopback0

R1(config-if)#ipv6 address 2006:1111::1/64

 

R1(config)#interface Serial0/0

R1(config-if)#ipv6 address 2007:16::1/64

R1(config-if)#ipv6 eigrp 1      

R1(config-if)#no shutdown

步骤2:配置路由器R6

R6(config)#ipv6 unicast-routing

 

R6(config)#ipv6 router eigrp 1

R6(config-rtr)#router-id 6.6.6.6

R6(config-rtr)#no shutdown

 

R6(config)#interface Serial0/0

R6(config-if)#ipv6 address 2007:16::6/64

R6(config-if)#clock rate 64000

R6(config-if)#ipv6 eigrp 1

R6(config-if)#no shutdown

 

R6(config)#interface Serial0/1

R6(config-if)#ipv6 address 2007:26::6/64

R6(config-if)#clock rate 64000

R6(config-if)#ipv6 eigrp 1

R6(config-if)#no shutdown

 

步骤3:配置路由器R2

R2(config)#ipv6 unicast-routing

R2(config)#ipv6 router eigrp 1

 

//在接口上启用IPv6 EIGRP

R2(config-rtr)# router-id 2.2.2.2

R2(config-rtr)#no shutdown

 

R2(config)#interface Serial0/0

R2(config-if)#ipv6 address 2007:23::2/64

R2(config-if)#clockrate 64000

R2(config-if)#ipv6 eigrp 1

R2(config-if)#no shutdown

 

R2(config)#interface Serial0/1

R2(config-if)#ipv6 address 2007:26::2/64

R2(config-if)#ipv6 eigrp 1

R2(config-if)#no shutdown

 

步骤4:配置路由器R3

R3(config)#ipv6 unicast-routing

 

R3(config)#ipv6 router eigrp 1

R3(config-rtr)# router-id 3.3.3.3

R3(config-rtr)#no shutdown

 

R3(config)#interface Loopback0

R3(config-if)#ipv6 address 2008:3333::3/64

R3(config-if)#ipv6 eigrp 1

 

R3(config)#interface Serial0/0

R3(config-if)#ipv6 address 2007:23::3/64

R3(config-if)#ipv6 eigrp 1

R3(config-if)#no shutdown

 

4.实验调试

1show ipv6 route eigrp

该命令用来查看 IPv6 EIGRP 的路由。

R1#show ipv6 route eigrp 

IPv6 Routing Table - 8 entries

Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

       U - Per-user Static route, M - MIPv6

       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

       D - EIGRP, EX - EIGRP external

D   2007:26::/64 [90/21024000]

     via FE80::219:55FF:FE66:6320, Serial0/0

D   2007:23::/64 [90/21536000]

     via FE80::219:55FF:FE66:6320, Serial0/0

D   2008:3333::/64 [90/21664000]

     via FE80::219:55FF:FE66:6320, Serial0/0

R6#show ipv6 route eigrp 

IPv6 Routing Table - 8 entries

Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

       U - Per-user Static route, M - MIPv6

I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

       D - EIGRP, EX - EIGRP external

EX  2006:1111::/64 [170/20537600]

     via FE80::219:55FF:FE35:B828, Serial0/0

D   2007:23::/64 [90/21024000]

     via FE80::219:55FF:FE35:B548, Serial0/1

D   2008:3333::/64 [90/21152000]

     via FE80::219:55FF:FE35:B548, Serial0/1

以上输出说明路由表中的下一跳是对方的本地链路地址,同时 IPv6 EIGRP 也能够区分

内部路由和外部路由,外部路由代码为EX

2show ipv6 eigrp neighbors

该命令用来查看 IPv6 EIGRP 的邻居。

R6#show ipv6 eigrp neighbors 

IPv6-EIGRP neighbors for process 1

H  Address                 Interface  Hold Uptime   SRTT  RTO  Q  Seq

                                      (sec)         (ms)       Cnt Num

1  Link-local address:     Se0/1     14  00:33:32   13   1140  0  24

   FE80::219:55FF:FE35:B548

0  Link-local address:     Se0/0     14  00:33:32   10   1140  0   9

   FE80::219:55FF:FE35:B828

以上输出表明路由器 R6 有两个 IPv6  EIGRP 邻居,邻居的地址用对方的本地链路地址表示。

  3show ipv6 eigrp topology

该命令用来查看 IPv6 EIGRP 的拓扑结构信息。

R6#show ipv6 eigrp topology 

IPv6-EIGRP Topology Table for AS(1)/ID(6.6.6.6)

 

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status 

 

P 2007:16::/64, 1 successors, FD is 20512000

        via Connected, Serial0/0

P 2006:1111::/64, 1 successors, FD is 20537600

        via FE80::219:55FF:FE35:B828 (20537600/281600), Serial0/0

P 2007:26::/64, 1 successors, FD is 20512000

        via Connected, Serial0/1

P 2007:23::/64, 1 successors, FD is 21024000

        via FE80::219:55FF:FE35:B548 (21024000/20512000), Serial0/1

P 2008:3333::/64, 1 successors, FD is 21152000

        via FE80::219:55FF:FE35:B548 (21152000/20640000), Serial0/1

4show ipv6 protocols

R6#show ipv6 protocols

 IPv6 Routing Protocol is "connected"

IPv6 Routing Protocol is "static"

IPv6 Routing Protocol is "eigrp 1"    

// IPv6 EIGRP进程

  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

//计算度量之的因子

  EIGRP maximum hopcount 100

//最大跳数

  EIGRP maximum metric variance 1

// variance 值为1,表示默认只支持等价路径负载均衡

  Interfaces:

    Serial0/0

    Serial0/1

//以上三行表示启用IPv6 EIGRP的接口

  Redistribution:

    None

  Maximum path: 16

//默认最大等价路径为16条,最多可以配置64

  Distance: internal 90 external 170

//IPv6 EIGRP 的内部路由管理距离为90,外部路由管理距离为170