算法提高 高精度除高精度

试题 算法提高 高精度除高精度

时间限制:1.0s 内存限制:256.0MB
问题描述
  给定a, b,求a/b。
输入格式
  输入两行,分别包含一个整数。
输出格式
  输出一行,为a/b的商。
样例输入
62349
64
样例输出
974
数据规模和约定
  1<=a<=10^10000, 1<=b<=10^10000。

package d算法提高;
import java.math.BigInteger;
import java.util.Scanner;

public class a7高精度除高精度 {
     

	public static void main(String[] args) {
     
		// TODO Auto-generated method stub
            Scanner in=new Scanner(System.in);
            BigInteger n=in.nextBigInteger();
            BigInteger m=in.nextBigInteger();
            BigInteger b=n.divide(m);
            System.out.println(b);
	}

}

你可能感兴趣的:(蓝桥杯算法提高,算法)