hdu1.2.6 GPA

Problem Description
Each course grade is one of the following five letters: A, B, C, D, and F. (Note that there is no grade E.) The grade A indicates superior achievement , whereas F stands for failure. In order to calculate the GPA, the letter grades A, B, C, D, and F are assigned the following grade points, respectively: 4, 3, 2, 1, and 0.
 
Input
The input file will contain data for one or more test cases, one test case per line. On each line there will be one or more upper case letters, separated by blank spaces.
 
Output
Each line of input will result in exactly one line of output. If all upper case letters on a particular line of input came from the set {A, B, C, D, F} then the output will consist of the GPA, displayed with a precision of two decimal places. Otherwise, the message "Unknown letter grade in input" will be printed.
 
Sample Input
A B C D F
B F F C C A
D C E F
 
Sample Output
2.00
1.83
Unknown letter grade in input

import java.io.FileInputStream;
import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.io.PrintWriter;
import java.io.OutputStreamWriter;
import java.io.StreamTokenizer;

public class Main implements Runnable
{
	private static final boolean DEBUG = false;
	private BufferedReader cin;
	private PrintWriter cout;
	private StreamTokenizer tokenizer;
	private String s;
	
	private void init() 
	{
		try {
			if (DEBUG) {
				cin = new BufferedReader(new InputStreamReader(
						new FileInputStream("d:\\OJ\\uva_in.txt")));
			} else {
				cin = new BufferedReader(new InputStreamReader(System.in));
			}

			cout = new PrintWriter(new OutputStreamWriter(System.out));
			//tokenizer = new StreamTokenizer(cin);
			
		} catch (Exception e) {
			e.printStackTrace();
		}
	}

	private String next()
	{
		try {
			/*
			tokenizer.nextToken();
			if (tokenizer.ttype == StreamTokenizer.TT_EOF) return null;
			else if (tokenizer.ttype == StreamTokenizer.TT_NUMBER) {
				return String.valueOf((int)tokenizer.nval);
			} else return tokenizer.sval;
			*/
			return cin.readLine();
		} catch (Exception e) {
			e.printStackTrace();
			return null;
		}
	}
	
	private boolean input() 
	{
		s = next();
		if (s == null) return false;
		
		return true;
	}
	
	private void solve() 
	{
		double sum = 0.0;
		int cnt = 0;
		boolean ok = true;
		
		
		for (int i = 0, len = s.length(); i < len; i++) {
			char ch = s.charAt(i);
			if (ch == 'A') {
				cnt++;
				sum += 4;
			} else if (ch == 'B') {
				cnt++;
				sum += 3;
			} else if (ch == 'C') {
				cnt++;
				sum += 2;
			} else if (ch == 'D') {
				cnt++;
				sum += 1;
			} else if (ch == 'F') {
				cnt++;
			} else if (ch == ' ') continue;
			else {
				ok = false;
				break;
			}
		}
		
		if (ok) {
			cout.printf("%.2f", sum / cnt);
			cout.println();
		} else {
			cout.println("Unknown letter grade in input");
		}
		cout.flush();
	}

	public void run()
	{
		init();
		
		while (input()) {
			solve();
		}
	}
	
	public static void main(String[] args) 
	{
		new Thread(new Main()).start();
	}
}



你可能感兴趣的:(#,hdu)