HDU 1556 Color the ball 树状数组

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10150    Accepted Submission(s): 5161


Problem Description
N 个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜 色了,你能帮他算出每个气球被涂过几次颜色吗?
 

 

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
 

 

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 

 

Sample Input
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 

 

Sample Output
1 1 1 3 2 1
 
Note
道题是一个区间更新,然后单点查询的问题
树状数组,套模版~
#include <cstdio>

#include <cmath>

#include <cstring>

#include <ctime>

#include <iostream>

#include <algorithm>

#include <set>

#include <vector>

#include <sstream>

#include <queue>

#include <typeinfo>

#include <fstream>

typedef long long ll;

using namespace std;

//freopen("D.in","r",stdin);

//freopen("D.out","w",stdout);

#define maxn 100001

int d[maxn];

int N,a,b;



int lowbit(int x)//求某点的管辖范围

{

    return x&(-x);

}



void update(int x,int num)//区间修改 使得a[1]一直修改到a[x]

{

    while(x>0)

     {

         d[x]+=num;

         x-=lowbit(x);

     }

}





int getSum(int x)//单点查询

{

    int s=0;

    while(x<=N)

     {

         s+=d[x];

         x+=lowbit(x);

     }

    return s;

}



int main()

{



    while(scanf("%d",&N)!=EOF)

    {

        if(N==0)

            break;

        memset(d,0,sizeof(d));

        for(int i=0;i<N;i++)

        {

            scanf("%d%d",&a,&b);

            update(a-1,-1);

            update(b,1);

        }

        int first=1;

        for(int i=1;i<=N;i++)

        {

            if(first==1)

            {

                printf("%d",getSum(i));

                first=0;

            }

            else

            {

                printf(" %d",getSum(i));

            }

        }

        printf("\n");

    }

    return 0;

}

 

你可能感兴趣的:(color)