hdu 1719

Friend

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2073    Accepted Submission(s): 1046

Problem Description
Friend number are defined recursively as follows. (1) numbers 1 and 2 are friend number; (2) if a and b are friend numbers, so is ab+a+b; (3) only the numbers defined in (1) and (2) are friend number. Now your task is to judge whether an integer is a friend number.
 
Input
There are several lines in input, each line has a nunnegative integer a, 0<=a<=2^30.
 
Output
For the number a on each line of the input, if a is a friend number, output “YES!”, otherwise output “NO!”.
 
Sample Input
3 13121 12131
 
Sample Output
YES! YES! NO!
 
Source
 
Recommend
lcy   |   We have carefully selected several similar problems for you:   1905  2082  1073  1715  1257 
心塞的一题。。。。。。。
friend 数为ab+a+b,那么可以变成(a+1)(b+1)-1,只要给一个数加上1,然后判断他是否是由一系列2和一系列3组成的,
因为所有的数都是有(a+1)(b+1) ,2,3递推而来的。
#include <iostream>

#include <cstdio>

#define LL int

using namespace std;



void solve(LL x)

{

    while((x%2)==0)

    {

        x/=2;

        if(x==1)

            break;

    }

    while((x%3)==0)

    {

        x/=3;

        if(x==1)

            break;

    }

    if(x==1)

       printf("YES!\n");

    else

        printf("NO!\n");

}

int main()

{

    LL x,T;

    while(~scanf("%d",&x))

    {

        if(x==1 || x==2)

            printf("YES!\n");

        if(x==0)

             printf("NO!\n");

        if(x!=1 && x!=2 && x!=0)

        solve(x+1);

    }

    return 0;

}

 

你可能感兴趣的:(HDU)