(HDOJ 1060)Leftmost Digit

 Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
     
       
2 3 4
 

Sample Output
     
       
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 
  Sample code:

   #include<stdio.h>

#include < math.h >
int  main()
{
     
int  n,a;
     scanf(
" %d " , & n);
     
while (n -- )
     {
       scanf(
" %d " , & a);
      
double  m = a * log10(a);
      
long   long  z = ( long   long )m;
      
double  p = m - z;
      
int  r = pow( 10 ,p);
      printf(
" %d\n " ,r);
     }
    
return   0 ;
}

 

 

你可能感兴趣的:(left)