HDU 3068 最长回文 (求最长回文子串)

最长回文

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3759    Accepted Submission(s): 1261


Problem Description
给出一个只由小写英文字符a,b,c...y,z组成的字符串S,求S中最长回文串的长度.
回文就是正反读都是一样的字符串,如aba, abba等
 

 

Input
输入有多组case,不超过120组,每组输入为一行小写英文字符a,b,c...y,z组成的字符串S
两组case之间由空行隔开(该空行不用处理)
字符串长度len <= 110000
 

 

Output
每一行一个整数x,对应一组case,表示该组case的字符串中所包含的最长回文长度.
 

 

Sample Input
aaaa abab
 

 

Sample Output
4 3
 

 

Source
 

 

Recommend
lcy
 
 
参考链接:
这个算法在上面讲得很清楚了。
//============================================================================

// Name        : HDU3068.cpp

// Author      : 

// Version     :

// Copyright   : Your copyright notice

// Description : Hello World in C++, Ansi-style

//============================================================================



#include <iostream>

#include <string.h>

#include <algorithm>

#include <stdio.h>

#include <math.h>

using namespace std;



int Proc(char pszIn[],char pszOut[])

{

    int nLen=1;

    pszOut[0]='$';

    int i=0;

    while(pszIn[i]!='\0')

    {

        pszOut[nLen++]='#';

        pszOut[nLen++]=pszIn[i];

        i++;

    }

    pszOut[nLen++]='#';

    pszOut[nLen]=0;

    return nLen;

}

void Manacher(int *p,char *str,int len)

{

    int mx=0,id=0;

    for(int i=0;i<len;i++)

    {

        p[i]=mx>i?min(p[2*id-i],mx-i):1;

        while(str[i+p[i]]==str[i-p[i]])p[i]++;

        if(i+p[i]>mx)

        {

            mx=i+p[i];

            id=i;

        }

    }

}

const int MAXN=220010;

char strIn[MAXN];

char strOut[MAXN];

int p[MAXN];

int main()

{

    while(scanf("%s",strIn)!=EOF)

    {

        int nLen=Proc(strIn,strOut);

        Manacher(p,strOut,nLen);

        int ans=1;

        for(int i=0;i<nLen;i++)

            ans=max(ans,p[i]);

        printf("%d\n",ans-1);

    }

    return 0;

}

 

你可能感兴趣的:(HDU)