杭电1004

Let the Balloon Rise

 

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

 

Sample Input
5 green red blue red red 3 pink orange pink 0
 

 

Sample Output
red pink
 

 

Author
WU, Jiazhi
 
 
#include<stdio.h>

#include<string.h>

#define MaxSize 1000

typedef struct

{

    char color[MaxSize];

    int size;

}COLOR;

COLOR color[1000];

int main()

{

    int n,i,j,first,max,t;

    char a[100],b[100];

    while(scanf("%d",&n)!=EOF&&n!=0)

    {

        

        for(i=0;i<n;i++)

        {

            scanf("%s",a);

            if(i==0)

            {

                strcpy(color[i].color,a);

                color[i].size=1;

            }

            else

            {

                first=0;

                for(j=0;j<i;j++)

                {

                    if(strcmp(a,color[j].color)==0)

                    {

                        color[j].size++;

                        first=1;

                    }

                }

                if(!first)

                {

                    strcpy(color[i].color,a);

                    color[i].size=1;

                }

            }

        }

        max=color[0].size;

        first=0;

        for(i=1;i<n;i++)

        {

            if(max<color[i].size)

            {

                max=color[i].size;

                t=i;

                first=1;

            }

            

        }

        if(first)

        printf("%s\n",color[t].color);

        else

        printf("%s\n",color[0].color);

    }

}

刚开始没想到用结构体在用二位动态数组做,想不到好办法来记录每种颜色的数量,后来参考网上同学的代码用结构体来记录每种颜色的数量,最后比较数量多少得出最多数量的颜色

 

你可能感兴趣的:(杭电)