The area

 

Problem Description
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.

The area
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
 
Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
 
Sample Input
2

5.000000 5.000000

0.000000 0.000000

10.000000 0.000000

10.000000 10.000000

1.000000 1.000000

14.000000 8.222222
 
Sample Output
33.33

40.69
Hint
For float may be not accurate enough, please use double instead of float
注意:平面图形的面积的积分公式适用范围
View Code
#include<iostream>

#include<cstdio>

using namespace std;

int main()

{

    int n;

    double x1,y1,x2,y2,x3,y3,a,b,c,k,d;

    //y1=a*x*x+b*x+c y2=k*x+d

    cin>>n;

    while(n--)

    {

     cin>>x1>>y1>>x2>>y2>>x3>>y3;

      a=((y1-y2)*(x1-x3)-(y1-y3)*(x1-x2))/((x1*x1-x2*x2)*(x1-x3)-(x1*x1-x3*x3)*(x1-x2));

      b=-2*a*x1;

      c=b*b/4/a+y1;

      k=(y3-y2)/(x3-x2);

      d=y2-k*x2;

    printf("%.2lf\n",a*(x3*x3*x3-x2*x2*x2)/3+(b-k)*(x3*x3-x2*x2)/2+(c-d)*(x3-x2));

    }

return 0;

}

 

你可能感兴趣的:(r)