OJ 3452 问题 E: C#判断回文字符串

题目描述

使用C#编写一个静态方法。该方法能够判断字符串是否是“回文”(即顺读和逆读相同的字符串)。

输入

一个字符串;

输出

如果是回文字符串,则输出“yes”,否则输出“no”;

样例输入

abcdcab

样例输出

no

using System;

namespace _3452E
{
	class Program
	{
		static void Main(string[] args)
		{
			string str = Console.ReadLine();
			char[] arr = str.ToCharArray();
			int len = arr.Length;
			int sum = 0;
			for (int i = 0; i < len; i++)
			{
				if (arr[i] == arr[len - 1 - i])
					sum++;
				else
					sum = sum;
			}
			if (sum == len)
				Console.WriteLine("yes");
			else
				Console.WriteLine("no");
		}
	}
}

你可能感兴趣的:(c#,oj系统)