hdu 2602

Time Limit: 1000MS   Memory Limit: 32768KB   64bit IO Format: %I64d & %I64u

 Status

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 
hdu 2602
 

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output

One integer per line representing the maximum of the total value (this number will be less than 2  31).
 

Sample Input

1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output

14
 

Source

HDU 1st “Vegetable-Birds Cup” Programming Open Contest
 
 
01背包
#include <iostream>

#include <algorithm>

#include <cstring>

#include <cstdio>

#include <cmath>



using namespace std;



    int T;

    int n,v;

    const int N=1E3+5;

    int a[N],b[N],dp[N];



void ZeroOnePack(int value, int cost)

{

    for ( int i = v ; i >= cost ; i-- )

        dp[i] = max(dp[i],dp[i-cost]+value);

}



int main()

{



    scanf("%d",&T);

    while ( T-- )

    {  memset(dp,0,sizeof(dp));



        scanf("%d %d",&n,&v);

        for ( int i = 1; i <= n ; i++ )

            scanf("%d",&a[i]);

        for ( int i = 1 ; i <= n ; i++ )

            scanf("%d",&b[i]);

        for ( int i = 1 ; i <= n ; i++ )

            ZeroOnePack(a[i],b[i]);

        printf("%d\n",dp[v]);

    }

    return 0;

}

 

你可能感兴趣的:(HDU)