Elevator

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case.  
 

Sample Input
    
      
1 2 3 2 3 1 0
 

Sample Output
    
      
17 41
 
     
       
#include < stdio.h >
int ComputeDistance( int a, int b)
{
int dis = 0 ;
if (a < b)
dis
= (b - a) * 6 + 5 ;
else
dis
= (a - b) * 4 + 5 ;
return dis;

}
void main()
{
int n,i;
int level[ 100 ];
int result[ 100 ] = { 0 };
int index = 0 ;
while (scanf( " %d " , & n) && n != 0 )
{
for (i = 0 ;i < n;i ++ ) // 数据的输入
scanf( " %d " , & level[i]);
for (i = 0 ;i < n;i ++ ) // 数据的处理
{
if (i == 0 )
result[index]
+= ComputeDistance( 0 ,level[i]);
else
result[index]
+= ComputeDistance(level[i - 1 ],level[i]);
}
index
++ ;
}
for (i = 0 ;i < index;i ++ )
printf(
" %d\n " ,result[i]);
}

你可能感兴趣的:(EL)