编写程序读取一系列整数,找出它们的最大数,然后计算该数的出现次数,假定输入以0结束。

编写程序读取一系列整数,找出它们的最大数,然后计算该数的出现次数,假定输入以0结束。输入格式

在一行中输入待统计的整型数,各个数可以以一个或多个空格或回车分隔,以0结束。

输出格式:

以两行输出: 第一行格式:The largest number is 最大数 第二行格式:The occurrence count of the largest number is 出现次数

输入样例:在这里给出一组输入。例如:

3 5 2 5 5 5 0

输出样例:

The largest number is 5
The occurrence count of the largest number is 4

package findmax;
import java.util.Scanner;
public class findmax {
	public static void main(String[] args) {
		Scanner input=new Scanner(System.in);
	    System.out.println(":");
		int a=input.nextInt();
		int max=a;
		int count=1;
		int i=1;
		while(a!=0)
		{
			if(max<a)
			{
				max=a;
				count=1;
			}
			else if(max==a)
			{
				if(i==1)
				count=1;
				else
				count++;
			}
		 a=input.nextInt();
		 i++;
		}
		System.out.println("The largest number is "+max);
		System.out.println("The occurrence count of the largest number is "+count);
	}
}

注意输入0的时候以及输入只有一个数的时候,代码有不妥的地方,解决办法不是很到位。欢迎指正!

你可能感兴趣的:(编写程序读取一系列整数,找出它们的最大数,然后计算该数的出现次数,假定输入以0结束。)