hdu 2176 取(m)石子游戏

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2176

题意分析:给出M堆石子,两人交替取子,给出先手能否胜利。 不能输出No, 能则输出Yes并给出第一次取子的个数。 典型的Nim博弈,先判断T态,若是非T态再求第一次取子的个数

/*取(m堆)石子游戏



Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1956    Accepted Submission(s): 1130





Problem Description

m堆石子,两人轮流取.只能在1堆中取.取完者胜.先取者负输出No.先取者胜输出Yes,然后输出怎样取子.例如5堆 5,7,8,9,10先取者胜,先取者第1次取时可以从有8个的那一堆取走7个剩下1个,也可以从有9个的中那一堆取走9个剩下0个,也可以从有10个的中那一堆取走7个剩下3个.

 



Input

输入有多组.每组第1行是m,m<=200000. 后面m个非零正整数.m=0退出.

 



Output

先取者负输出No.先取者胜输出Yes,然后输出先取者第1次取子的所有方法.如果从有a个石子的堆中取若干个后剩下b个后会胜就输出a b.参看Sample Output.

 



Sample Input

2

45 45

3

3 6 9

5

5 7 8 9 10

0

 



Sample Output

No

Yes

9 5

Yes

8 1

9 0

10 3

 



Author

Zhousc

 



Source

ECJTU 2008 Summer Contest

 

*/

#include <iostream>

#include <cstdio>

#include <cstring>

using namespace std;

const int maxn = 200000 + 10;

int N[maxn], m;

void solve()

{

     int flag = N[0], cnt;

     for(int i = 1; i < m; i++) flag ^= N[i];

     if(flag == 0) printf("No\n");

     else{

         printf("Yes\n");

         for(int i = 0; i < m; i++){

             cnt = N[i]^flag;

             if(cnt < N[i])

                 printf("%d %d\n", N[i], cnt);

         }

     }

}



int main()

{

    while(~scanf("%d", &m) && m){

        for(int i = 0; i < m; i++)

            scanf("%d", &N[i]);

        solve();

    }

    return 0;

}

 

你可能感兴趣的:(HDU)